Our IT team resolved the issue with support.jenzabar.com. Please return to the portal for all your support needs.
We apologize for any inconvenience this may cause and appreciate your patience.
Posted Nov 01, 2025 - 07:07 EDT
Investigating
We are currently experiencing a known outage affecting support.jenzabar.com.
Our IT team is actively working to resolve the issue and restore full functionality as quickly as possible.
What you need to know: • Impact: Access to support.jenzabar.com is unavailable. • Next Update: We will provide additional information as soon as it becomes available.
We apologize for any inconvenience this may cause and appreciate your patience while we work to resolve the issue.
Posted Oct 31, 2025 - 13:50 EDT
This incident affected: Jenzabar Data Centers (North America East, North America Central, US Central 1, US East 1, US East 5, US West 1) and SONIS, Jenzabar One & EX, Higher Reach, CX.